48 lines
970 B
Nix
48 lines
970 B
Nix
_: {
|
|
imports = [
|
|
./hardware
|
|
./programs
|
|
./services
|
|
./containers
|
|
./network
|
|
./security.nix
|
|
];
|
|
|
|
nodeconfig = {
|
|
minimize = true;
|
|
nix.auto-gc = true;
|
|
is-pi = true;
|
|
is-server = true;
|
|
facts = {
|
|
external-ip = null;
|
|
local-ip = "192.168.1.12";
|
|
wireguard-ip = "10.10.10.12";
|
|
};
|
|
};
|
|
|
|
i18n = {
|
|
defaultLocale = "en_US.UTF-8";
|
|
extraLocaleSettings = {
|
|
LC_ADDRESS = "en_US.UTF-8";
|
|
LC_IDENTIFICATION = "en_US.UTF-8";
|
|
LC_MEASUREMENT = "en_US.UTF-8";
|
|
LC_MONETARY = "en_US.UTF-8";
|
|
LC_NAME = "en_US.UTF-8";
|
|
LC_NUMERIC = "en_US.UTF-8";
|
|
LC_PAPER = "en_US.UTF-8";
|
|
LC_TELEPHONE = "en_US.UTF-8";
|
|
LC_TIME = "en_US.UTF-8";
|
|
LC_ALL = "en_US.UTF-8";
|
|
};
|
|
supportedLocales = [ "en_US.UTF-8/UTF-8" ];
|
|
};
|
|
|
|
time.timeZone = "Asia/Kolkata";
|
|
system = {
|
|
switch = {
|
|
enable = false;
|
|
enableNg = true;
|
|
};
|
|
stateVersion = "23.11";
|
|
};
|
|
}
|